summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel YC Lin2015-06-13 14:25:57 +0800
committerDaniel YC Lin2015-06-13 14:25:57 +0800
commit093f4411a5b61bb45fef32546d80017f062c39e1 (patch)
tree6aa222fe22e7606c1a81b5d08156562f8ba8dcd5 /PKGBUILD
downloadaur-python2-grs-git.tar.gz
merge to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c341a69d4d9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Daniel YC Lin <dlin.tw at gmail>
+
+pkgname=python2-grs-git
+pkgver=v0.6.2.r0.g3a7681d
+_pkgname=grs
+pkgrel=1
+pkgdesc="Fetch TWSE stock data"
+arch=('any')
+url="https://pypi.python.org/pypi/grs"
+license=('custom')
+depends=('python2' 'python2-dateutil')
+makedepends=()
+
+source=("$_pkgname"::git+https://github.com/toomore/grs)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ #printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+# vim:set ts=2 sw=2 et:
+md5sums=('SKIP')