summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commit8b3b89a45e809fe07bfd594a6955eae8586cf0d4 (patch)
treef4375bf18e78ed2db3e95c61943d45cbfe73638d /PKGBUILD
downloadaur-8b3b89a45e809fe07bfd594a6955eae8586cf0d4.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16438edbc88f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-humanfriendly
+pkgver=1.27
+pkgrel=1
+pkgdesc="Human friendly output for text interfaces using Python"
+arch=('any')
+depends=('python2')
+makedepends=('python2-setuptools')
+url="https://humanfriendly.readthedocs.org"
+license=('MIT')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/h/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
+md5sums=('cb63c7cb30a1e7fd903bbdc8091925ac')
+sha256sums=('b80c391baf5c7d5f634391d62c9869c4d20dd6167c53ba2e3765f9ad2bc54638')
+provides=('humanfriendly' 'python2-humanfriendly')
+conflicts=('humanfriendly')
+
+package() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}