summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorValHue2015-06-09 13:15:49 +0200
committerValHue2015-06-09 13:15:49 +0200
commit68aa4d1cd15f2340cc98e369eb28593e49f4d444 (patch)
tree90b8239968584e1f3ff96524ee445a7af7e4ca34 /PKGBUILD
downloadaur-68aa4d1cd15f2340cc98e369eb28593e49f4d444.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..016d6fd76538
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# Contributor: György Balló <ballogy at freestart dot hu>
+
+_pkgname=lazr.restfulclient
+pkgname=python2-lazr-restfulclient
+pkgver=0.13.3
+pkgrel=1
+pkgdesc="A programmable client library that takes advantage of the commonalities among lazr.restful web services to provide added functionality on top of wadllib"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/lazr.restfulclient"
+license=('LGPL')
+depends=('python2-httplib2' 'python2-oauth2' 'python2-wadllib')
+source=("http://launchpad.net/${_pkgname}/trunk/${pkgver}/+download/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('ed421f226bbafabf7453c6c32b2f366e')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}