summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFup Duck2017-11-17 22:57:15 +0100
committerFup Duck2017-11-17 22:57:15 +0100
commit6385fce12baf6aa203021214b6747ad5dea79359 (patch)
tree4e2370b80d0093928524d9c364c795861f8390f7 /PKGBUILD
downloadaur-6385fce12baf6aa203021214b6747ad5dea79359.tar.gz
create package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a6c22289f8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Felix Höffken <fupduck at sacknagel dot com>
+
+_srcname=leap.pixelated-www
+pkgname=python2-$_srcname
+pkgver=1.0.201709121424
+pkgrel=1
+pkgdesc='Static Assets for the Pixelated User Agent UI'
+arch=('any')
+url='http://github.com/leapcode/pixelated-user-agent'
+license=('AGPL3')
+
+source=("https://files.pythonhosted.org/packages/source/${_srcname::1}/${_srcname}/${_srcname}-${pkgver}.tar.gz")
+sha256sums=('142477d3fe31921af2bfbbec4c7fe9472edf8c15e5c5317f96631a6b66398f0f')
+
+build() {
+ cd "$srcdir/$_srcname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_srcname-$pkgver"
+ python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
+}