summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOlivier Medoc2016-03-16 11:10:35 +0000
committerOlivier Medoc2016-03-16 11:10:35 +0000
commit4560b4645f747c3a125d13276c23d5f959e236a8 (patch)
tree56f65267e5293a5856b59148513cb2b00b920d5c /PKGBUILD
downloadaur-4560b4645f747c3a125d13276c23d5f959e236a8.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..cf58ded8fe1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=python2-liblnk
+_pkgcode=liblnk
+pkgver=20151205
+pkgrel=1
+pkgdesc="Library and tools to access the Windows Shortcut File (LNK) format"
+url="https://github.com/libyal/liblnk/"
+arch=('any')
+license=('LGPLv3+')
+
+depends=('python2')
+makedepends=('python2' 'gcc')
+
+md5sum=e1bc3423fb60fc4d365e2ab094b97a39
+source=(https://pypi.python.org/packages/source/l/$_pkgcode-python/$_pkgcode-python-$pkgver.tar.gz#md5=$md5sum)
+md5sums=($md5sum)
+
+build() {
+ cd $srcdir/${_pkgcode}-${pkgver}
+
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/${_pkgcode}-${pkgver}
+ python2 setup.py install --root="${pkgdir}"
+}