summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Feuls2016-05-26 20:54:55 +0200
committerCarsten Feuls2016-05-26 20:54:55 +0200
commit6a96fec8e4a4291bb3d2edf2d4e4e25548667ae9 (patch)
tree86269d8253e8b86ccc34561d39b7a55fccde1dae /PKGBUILD
downloadaur-python2-libusb1.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7a600755141
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Carsten Feuls <archlinux@carstenfeuls.de>
+
+pkgname=python2-libusb1
+_pkgname=libusb1
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="Pure python wrapper for libusb"
+arch=('any')
+url="https://github.com/vpelletier/${pkgname}"
+license=('GPL2')
+makedepends=('git' 'python2-distutils-extra' 'python2-setuptools')
+depends=('python2' 'libusbx')
+optdepends=()
+conflicts=("${pkgname}-git")
+source=("git+https://github.com/vpelletier/python-libusb1.git")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/python-libusb1"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/python-libusb1"
+ python2 setup.py install --root="${pkgdir}" \
+ --prefix="/usr" \
+ --compile -O1
+}