summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Kitching2018-07-12 18:01:07 +0100
committerChris Kitching2018-07-12 18:01:34 +0100
commit7de3a33be699c1c5a80a5511b399a5848dd619ff (patch)
tree4bee8f8bbca90ea6e6b5c79b8a40baf10dee6fa3 /PKGBUILD
parent37cfd660867b1b3c065877f2bf5b5b1296ac06a5 (diff)
downloadaur-python2-llvm-lit.tar.gz
Fix python package versioning sillies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 18 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4e47e8c7cae..a0f102e8cc92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,25 @@ pkgname=python2-llvm-lit
pkgver=6.0.1
pkgrel=1
pkgdesc="LLVM integrated tester"
-arch=('x86_64')
+arch=('any')
depends=(python2 python2-pip)
-source=("https://releases.llvm.org/$pkgver/llvm-$pkgver.src.tar.xz")
-md5sums=('c88c98709300ce2c285391f387fecce0')
+source=(
+ "https://releases.llvm.org/$pkgver/llvm-$pkgver.src.tar.xz"
+ versioning.patch
+)
+md5sums=(
+ 'c88c98709300ce2c285391f387fecce0'
+ '9f54e688dd2028c9bfa861f67607f3e4'
+)
+
+prepare() {
+ cd llvm-$pkgver.src
+ # Patch to cope with silly Python package versioning.
+ # llvm-lit is hardcoded to append `-dev` to the Python package version. Python versioning
+ # rules say that version 0.6.0-dev < 0.6.0, so downstream packages like lnt fail because
+ # the installed version of llvm-lit is "too old".
+ patch -p1 < $srcdir/versioning.patch
+}
build() {
cd "llvm-$pkgver.src/utils/lit"