summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Heitzmann Gabrielli2015-06-25 20:58:36 -0300
committerLucas Heitzmann Gabrielli2015-06-25 20:58:36 -0300
commit31e869cba09045ab61f6656833054ed4e32e9db4 (patch)
tree7e325c5bddf82123318ee4a9707ebfc00cc359b4 /PKGBUILD
downloadaur-31e869cba09045ab61f6656833054ed4e32e9db4.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..530141cffcdd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
+pkgname=python2-meep
+pkgver=1.4.2
+pkgrel=1
+pkgdesc="Python binding for MEEP (FDTD solver by MIT)"
+url="https://launchpad.net/python-meep"
+arch=('x86_64' 'i686')
+license=('GPL')
+depends=('python2' 'python2-numpy' 'python2-scipy' 'python2-matplotlib' 'meep' 'openmpi' 'swig')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("https://launchpad.net/python-meep/1.4/1.4/+download/python-meep-${pkgver}.tar")
+md5sums=('f8913542d18b0dda92ebc64f0a10ce56')
+
+build() {
+ cd "${srcdir}/python-meep"
+ tail -n +3 meep-site-init.py.standard > meep-site-init.py
+ python2 setup-mpi.py clean --all
+ python2 setup-mpi.py build_ext
+}
+
+package() {
+ cd "${srcdir}/python-meep"
+ python2 setup-mpi.py install --prefix=/usr --root=${pkgdir}
+}
+
+# vim:set ts=2 sw=2 et: