summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLingMan2021-06-30 14:53:49 +0200
committerLingMan2021-06-30 14:56:04 +0200
commita9f4615b72b41498f6cc68b4ae967a08dc9e825d (patch)
tree69b73f5086b4ac9b8525053faedf33ec41faeee4 /PKGBUILD
downloadaur-python2-mistune.tar.gz
AUR submission after python2 support was dropped from the main repos in
https://github.com/archlinux/svntogit-community/commit/daa64f14d2d91929885774a1afe661d8902d3154
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3517f9f9afa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+
+pkgname=python2-mistune
+pkgver=0.8.4
+pkgrel=6
+pkgdesc="The fastest markdown parser in pure Python with renderer feature."
+arch=('any')
+url="https://github.com/lepture/mistune"
+license=('BSD')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("$pkgname-$pkgver.tgz::https://github.com/lepture/mistune/archive/refs/tags/v$pkgver.tar.gz")
+sha512sums=('44f155966e135ae157a8769e566119d86d1cdae28a4c27ecb54c33a9497096d0d4284a98da0c1bd47195f1b5c83e293b9655a912431adb18bfe84766ba1adc15')
+
+package() {
+ cd "$srcdir/mistune-$pkgver"
+ python2 setup.py install --root="$pkgdir/"
+ install -D -m644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}