summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPellegrino Prevete2023-02-11 16:06:27 +0000
committerPellegrino Prevete2023-02-11 16:06:27 +0000
commitae28d3ab022ab3ca315b0464f77c3e47fe5ee93b (patch)
treef395dab52b3479bbe55627bea9fdb5f8ff4438d7 /PKGBUILD
parent8602715c5a163428bc91be257751d2f19d02dd2a (diff)
downloadaur-python2-mock.tar.gz
fork from marsseed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c32334f58644..40ab71483c0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
-# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Maintainer: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: jelle van der Waa <jelle@vdwaa.nl>
# Contributor: Felix Kaiser <felix.kaiser@fxkr.net>
+# Contributor: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+
pkgname='python2-mock'
_name="${pkgname#python2-}"
@@ -15,6 +17,7 @@ depends=(
'python2-funcsigs'
'python2-pbr'
'python2-six'
+ 'python2-typing'
)
_tarname="${_name}-${pkgver}"
source=("${_tarname}::https://github.com/testing-cabal/${_name}/archive/${pkgver}.tar.gz")
@@ -32,12 +35,6 @@ build() {
python2 setup.py build
}
-check() {
- cd "${_tarname}"
-
- python2 -m unittest discover
-}
-
package() {
cd "${_tarname}"