summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2022-06-03 04:57:07 -0400
committerTony Lambiris2022-06-03 04:57:07 -0400
commit6bc95de1b5d07eb81c3c59b7b81fb6cfc6f33819 (patch)
treef82e5e39473342062af68895a01f44943a5f2b15 /PKGBUILD
parentee36ee375892ab99c26930efaf7e66a4fecd483d (diff)
downloadaur-6bc95de1b5d07eb81c3c59b7b81fb6cfc6f33819.tar.gz
Version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 15 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c99301b6bd10..f25b9dd7ce66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,35 @@
-# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
+# Maintainer: Tony Lambiris <tony@libpcap.net>
+# Contributor: Johannes Löthberg <johannes@kyriasis.com>
# Contributor: Sébastien "Seblu" Luttringer
pkgname=python2-msgpack
-pkgver=0.6.2
-pkgrel=4
+pkgver=1.0.4
+pkgrel=1
pkgdesc='MessagePack serializer implementation for Python'
-
-
url='https://github.com/msgpack/msgpack-python'
arch=('x86_64')
license=('Apache')
-
depends=('python2')
makedepends=('cython2' 'python2-setuptools')
checkdepends=('python2-pytest' 'python2-six')
-
source=(msgpack-python-$pkgver.tar.gz::https://github.com/msgpack/msgpack-python/archive/v$pkgver.tar.gz)
-
-sha512sums=('be4a65592acf3c2a4fcd5d6c603f5a3346f0bccb4864d82a729d47308a11d990f7137e66a9d6df7309a892d189f62e8a9efbda022b7ef2a09338012aa1634b6d')
+sha256sums=('4fd3e3e99c652e8ef435940a7f59ae751f3c5f4ef89fa5aa1b951e7cc80c1972')
build() {
- cd msgpack-python-$pkgver
- python2 setup.py build --build-lib=build/python
+ cd "${srcdir}/msgpack-python-${pkgver}"
+
+ python2 setup.py build --build-lib=build/python
}
check() {
- cd msgpack-python-$pkgver
- PYTHONPATH=$PWD/build/python py.test2 test
+ cd "${srcdir}/msgpack-python-${pkgver}"
+
+ env PYTHONPATH="$PWD/build/python" py.test2 test
}
package() {
- cd msgpack-python-$pkgver
- python2 setup.py build --build-lib=build/python \
- install --root="$pkgdir" --optimize=1
-}
+ cd "${srcdir}/msgpack-python-${pkgver}"
-# vim:set ts=2 sw=2 et:
+ python2 setup.py build --build-lib=build/python \
+ install --root="${pkgdir}" --optimize=1
+}