summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeert Hendrickx2017-04-22 22:32:27 +0200
committerGeert Hendrickx2017-04-22 22:32:27 +0200
commita55cf7f2ed26130ad2d1200e4c70cd0750411860 (patch)
treea8b86b22e1da996a55f01592afb4c4a396d54a7c /PKGBUILD
downloadaur-a55cf7f2ed26130ad2d1200e4c70cd0750411860.tar.gz
Re-import python-mtools as python2-mtools and co-adopt.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e74a5a70e44d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: reno.esper@gmail.com
+# Maintainer: geert@hendrickx.be
+
+pkgname=python2-mtools
+_pkgname=mtools
+pkgver=1.2.3
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/rueckstiess/mtools"
+pkgdesc="A collection of scripts to set up MongoDB test environments and parse and visualize MongoDB log files"
+license=('Apache License')
+depends=('python2' 'python2-dateutil' 'python2-setuptools')
+optdepends=('python2-psutil' 'python2-pymongo' 'python2-matplotlib' 'python2-numpy')
+makedepends=('python2-setuptools')
+source=("https://github.com/rueckstiess/mtools/archive/v$pkgver.tar.gz")
+sha256sums=('3fa09109bc986bef5081f743db43bc87c3b41f0414556c9bf0f1e10364389c0a')
+
+package() {
+ cd $srcdir/$_pkgname-${pkgver}
+ python2 setup.py install --root=$pkgdir
+}