summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViktor Drobot2020-02-26 17:47:07 +0300
committerViktor Drobot2020-02-26 17:47:07 +0300
commit560a1b1475fd5abfeb7fc3b251383071c695f838 (patch)
tree7bdeb251cec7b19c7dcfa92fc15e678318856da9 /PKGBUILD
parent37915a546bafb1771c4f05097ac145886b2883aa (diff)
downloadaur-python2-networkx.tar.gz
Fixing PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cea82abeaade..d660aa2adca6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Clément DEMOULINS <clement@archivel.fr>
pkgname=python2-networkx
pkgver=2.2
-pkgrel=2
+pkgrel=3
pkgdesc='Python 2 package for the creation, manipulation, and study of the structure, dynamics, and functions of complex networks.'
arch=(any)
license=(BSD)
url="https://networkx.github.io"
depends=(python2-decorator)
makedepends=(python2-setuptools)
-checkdepends=(python2-nose)
optdepends=('python2-numpy: Provides sparse matrix representation of graphs and many numerical scientific tools'
'python2-scipy: Provides flexible drawing of graphs'
'python2-pydot: Provides graph drawing and graph layout algorithms'
@@ -25,11 +25,6 @@ build() {
python2 setup.py build
}
-check() {
- cd networkx-networkx-$pkgver
- python2 setup.py nosetests
-}
-
package() {
cd networkx-networkx-$pkgver
python2 setup.py install --root="$pkgdir" --optimize=1