summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGunnar Waterstraat2018-06-04 15:01:47 +0200
committerGunnar Waterstraat2018-06-04 15:01:47 +0200
commit1bbfbd8b2ea9df4adc56518350394efbf5eccead (patch)
tree493e9933e1b00cd036c1898899688b3e122752e2 /PKGBUILD
downloadaur-1bbfbd8b2ea9df4adc56518350394efbf5eccead.tar.gz
initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..707f3394488a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Gunnar Waterstraat <gunnar.waterstraat@gmx.de>
+pkgname=python2-nibabel-git
+pkgver=2.2.1.r228.g2edca761
+pkgrel=1
+pkgdesc="Python package to access a cacophony of neuro-imaging file formats"
+arch=('any')
+url="http://nipy.org/nibabel/"
+license=('MIT' 'custom')
+depends=('python2>=2.7' 'python2-numpy>=1.7.1' 'python2-six>=1.3')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('nibabel::git+http://github.com/nipy/nibabel.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd nibabel
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "nibabel"
+ python2 setup.py build
+}
+
+package() {
+ cd "nibabel"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}