summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Goldsmith2020-04-08 03:56:34 -0400
committerAdam Goldsmith2020-04-08 03:57:08 -0400
commit372bbf6b6042b3a4f8d6f208490293ce1676180e (patch)
tree09bee7dd94dfaeb9e52347c82fb1328d7c0fd135 /PKGBUILD
downloadaur-python2-oauth2client.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c62cc10df7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Adam Goldsmith <adam@adamgoldsmith.name>
+
+_name=oauth2client
+pkgname=python2-$_name
+pkgver=4.1.3
+pkgrel=1
+pkgdesc="OAuth 2.0 client library"
+arch=(any)
+url="https://github.com/googleapis/oauth2client"
+license=('Apache')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('3a9eb781f685949c04946f6c09e4c11d')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: