summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAaron DeVore2015-07-08 11:19:24 -0700
committerAaron DeVore2015-07-08 11:19:24 -0700
commitee7d538935584f4234098db101b09c30d4712f8e (patch)
treed5a7b7354d022b326890b3283746b2d7c884d18d /PKGBUILD
downloadaur-ee7d538935584f4234098db101b09c30d4712f8e.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28617e30ce59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Vinicius de Avila <vinicius.avila.jorge@gmail.com>
+# Update Based on Geoff Teale's PKGBUILD. To support only python2
+pkgname=python2-odfpy
+pkgver=0.9.6
+pkgrel=1
+pkgdesc="A complete API for OpenDocument in Python. Python 2.x support"
+arch=('i686' 'x86_64')
+url="http://opendocumentfellowship.com/projects/odfpy"
+license=('GPL')
+depends=('python2')
+conflicts=('odfpy' 'python-odfpy' 'python3-odfpy' 'python-all-odfpy')
+source=("http://pypi.python.org/packages/source/o/odfpy/odfpy-$pkgver.tar.gz")
+md5sums=('3f570ead2b5f5eb6eab97eecce22d491')
+
+build() {
+ cd "$srcdir/odfpy-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/odfpy-${pkgver}"
+ python2 setup.py install --root=${pkgdir}
+}