summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSpyros Stathopoulos2019-10-14 00:10:39 +0100
committerSpyros Stathopoulos2019-10-14 00:10:39 +0100
commit3aa9d7b68cd48bfda549e4e4538ab7a622b21f22 (patch)
tree2f8480256bcfe70c1777b37a5f47572cbf9ae5be /PKGBUILD
downloadaur-3aa9d7b68cd48bfda549e4e4538ab7a622b21f22.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ec40caa176f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: Spyros Stathopoulos <spystath@gmail.com>
+pkgname="python2-pandas"
+_pkgname="pandas"
+pkgver=0.24.2
+pkgrel=1
+pkgdesc="R-like data analysis library for Python (final Python 2.x version)."
+url="http://pandas.pydata.org"
+depends=('python2' 'python2-numpy' 'python2-dateutil')
+optdepends=("python2-numexpr: for accelerating certain numerical operations (recommended)"
+ "python2-bottleneck: for accelerating certain types of nan evaluations (recommended)"
+ "python2-scipy: for miscellaneous statistical functions"
+ "python2-pytables: for HDF5-based storage"
+ "python2-matplotlib: for plotting"
+ "scikits-statsmodels: for parts of pandas.stats"
+ "python2-openpyxl>=1.6.1: for Excel I/O"
+ "python2-xlrd: for Excel I/O"
+ "python2-xlwt: for Excel I/O"
+ "python2-boto: for Amazon S3 access"
+ "python2-beautifulsoup4: for read_html function"
+ "python2-html5lib: for read_html function"
+ "python2-lxml: for read_html function")
+makedepends=("cython2")
+arch=("i686" "x86_64")
+license=("BSD")
+md5sums=("6640de14a934a701129b635c6d75801d")
+
+source=("https://github.com/pandas-dev/pandas/releases/download/v${pkgver}/pandas-${pkgver}.tar.gz")
+
+build() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
+
+ python2 setup.py build_ext --inplace
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/python2-pandas/LICENSE
+ python2 setup.py install --root=${pkgdir} --optimize=1
+}
+