summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAchilleas Pipinellis2020-01-05 21:39:46 +0100
committerAchilleas Pipinellis2020-01-05 21:39:46 +0100
commite9f41c4025e53185119460b3783a2fff17a029fd (patch)
treee51c3e12151e9b69ec51c91529cba8ee76aa5ddd /PKGBUILD
parent1f01e40f18b3555b844eae5cb9618dd3e6ab77b8 (diff)
downloadaur-python2-parsley-git.tar.gz
Update package details
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7321088170d8..6af18ab03b6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Contributor: Justin Hale <justinhale at ganja.nl>
-# Maintainer: Achilleas Pipinellis <axilleas archlinux info>
+# Maintainer: Achilleas Pipinellis <axilleas archlinux gr>
+
pkgname=python2-parsley-git
-pkgver=r357.d83692a
+pkgver=r362.c89b3f0
pkgrel=1
pkgdesc="A parser generator library based on OMeta, and other useful parsing tools."
arch=('any')
-url="https://github.com/python-parsley/parsley"
+url="https://github.com/pyga/parsley"
license=('MIT')
depends=('python2')
conflicts=('python2-parsley')
@@ -18,9 +19,14 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd "$pkgname"
+ python2 setup.py build
+}
+
package() {
cd "$pkgname"
- python2 setup.py install --root=$pkgdir -O1
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
# vim:set ts=2 sw=2 et: