summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAchilleas Pipinellis2015-06-10 09:15:18 +0300
committerAchilleas Pipinellis2015-06-10 09:15:18 +0300
commit1f01e40f18b3555b844eae5cb9618dd3e6ab77b8 (patch)
tree09f9d546eb21bbca700cbbc4fc85639ed105ed3a /PKGBUILD
downloadaur-1f01e40f18b3555b844eae5cb9618dd3e6ab77b8.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7321088170d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Justin Hale <justinhale at ganja.nl>
+# Maintainer: Achilleas Pipinellis <axilleas archlinux info>
+pkgname=python2-parsley-git
+pkgver=r357.d83692a
+pkgrel=1
+pkgdesc="A parser generator library based on OMeta, and other useful parsing tools."
+arch=('any')
+url="https://github.com/python-parsley/parsley"
+license=('MIT')
+depends=('python2')
+conflicts=('python2-parsley')
+makedepends=('git' 'python2-setuptools')
+source=("${pkgname}::git+https://github.com/python-parsley/parsley.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ python2 setup.py install --root=$pkgdir -O1
+}
+
+# vim:set ts=2 sw=2 et: