summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Goldsmith2015-07-26 20:02:19 -0400
committerAdam Goldsmith2015-07-26 20:02:19 -0400
commit52cdb9dcd8eae9840acff0018f2c06724aee54dc (patch)
treefa862a3b813a233fc59519ca9dbe06e7c8cbde72 /PKGBUILD
downloadaur-52cdb9dcd8eae9840acff0018f2c06724aee54dc.tar.gz
migrate to AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81f1678fae20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: juantascon
+# Submitter: Dennis Fink <the_metalgamer@hackerspace.lu>
+# Submitter: sevkin
+
+pkgname=python2-peewee
+pkgver=2.5.1
+pkgrel=2
+pkgdesc="a little orm"
+url="https://pypi.python.org/pypi/peewee/"
+arch=('any')
+license=('MIT')
+depends=('python2')
+optdepends=('python2-psycopg2' 'mysql-python')
+source=(http://pypi.python.org/packages/source/p/peewee/peewee-$pkgver.tar.gz)
+
+build() {
+ cd $srcdir/peewee-$pkgver
+ python2 setup.py build
+}
+
+package() {
+
+ cd $srcdir/peewee-$pkgver
+ python2 setup.py install --root=$pkgdir --optimize=1
+ install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/COPYING
+ install -D -m644 README.rst $pkgdir/usr/share/$pkgname/README.rst
+ install -D -m644 TODO.rst $pkgdir/usr/share/$pkgname/TODO.rst
+ cd $pkgdir/usr/bin
+ mv pwiz.py pwiz.py-python2
+
+}
+
+sha1sums=('391c45e480e36ace9128c282d1ed068d505f9a3c')