summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTruocolo2024-01-27 14:26:55 +0100
committerTruocolo2024-01-27 14:26:55 +0100
commit8de066f0f3fd9830b1c6b227c884f332c92c9773 (patch)
tree25442e3224032784e3326edc8c239f7fecb19efd /PKGBUILD
parent3ed3b2d0f791b14c02c4338b1b7495f8ef943b29 (diff)
downloadaur-python2-pkgconfig.tar.gz
bump ver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 29 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 52d9bc18f44d..75237aa9f839 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,29 @@
+# SPDX-License-Identifier: AGPL-3.0
+#
# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+# Maintainer: Truocolo <truocolo@aol.com>
# Contributor: Infernio <infernio at icloud dot com>
# Contributor: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Marcell Meszaros (MarsSeed) <marcell.meszaros@runbox.eu>
_py="python2"
_pkg="pkgconfig"
pkgname="${_py}-${_pkg}"
-pkgver=1.5.1
+pkgver=1.5.2
pkgrel=1
-pkgdesc="Python 2 module to interface with the pkg-config command line tool"
-arch=(any)
+_pkgdesc=(
+ "Python 2 module to interface with"
+ "the pkg-config command line tool"
+)
+pkgdesc="${_pkgdesc[*]}"
+arch=(
+ any
+)
_ns="matze"
url="https://github.com/${_ns}/${_pkg}"
-license=(MIT)
+license=(
+ MIT
+)
depends=(
"${_py}"
)
@@ -23,16 +35,23 @@ source=(
"${_pypi_url}/${_pkg::1}/${_pkg}/${_pkg}-${pkgver}.tar.gz"
)
sha256sums=(
- '97bfe3d981bab675d5ea3ef259045d7919c93897db7d3b59d4e8593cba8d354f'
+ '38d612488f0633755a2e7a8acab6c01d20d63dbc31af75e2a9ac98a6f638ca94'
)
package() {
- cd "${_pkg}-${pkgver}"
+ cd \
+ "${_pkg}-${pkgver}"
- "${_py}" setup.py install --prefix=/usr \
- --root="${pkgdir}" \
- --optimize=1
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ "${_py}" \
+ setup.py \
+ install \
+ --prefix=/usr \
+ --root="${pkgdir}" \
+ --optimize=1
+ install \
+ -Dm644 \
+ LICENSE \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set sw=2 sts=-1 et: