summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViktor Drobot2019-11-15 19:04:13 +0300
committerViktor Drobot2019-11-15 19:04:13 +0300
commit4d3ea574af3d3b61d02a4d493f32ef399e2f0fec (patch)
tree1e9a9ef4c2d21e3791a1a6ec25c2b742c5bc237f /PKGBUILD
downloadaur-python2-pmw.tar.gz
First release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c71e6a322f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+pkgname=python2-pmw
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="A toolkit for high-level compound widgets in Python using the Tkinter module"
+arch=('any')
+url="http://pmw.sourceforge.net/"
+license=('MIT')
+depends=('python2' 'tk')
+source=("${pkgname}-${pkgver}.tar.gz::https://pypi.python.org/packages/source/P/Pmw/Pmw-${pkgver}.tar.gz")
+md5sums=('8080b0fabc731ff236f97e88e13b3938')
+
+prepare() {
+ cd "${srcdir}/Pmw-${pkgver}"
+
+ find . -name '*.py' -exec \
+ sed -i "s|python|python2|g" {} \;
+}
+
+build() {
+ cd "${srcdir}/Pmw-${pkgver}"
+
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/Pmw-${pkgver}"
+
+ python2 setup.py install --prefix=/usr --root="${pkgdir}"
+}