summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMoritz Lipp2015-06-15 20:18:44 +0200
committerMoritz Lipp2015-06-15 20:18:44 +0200
commit15db01c9c84b2b700f06b7a495cecd318ff0cbb5 (patch)
tree3720430f2d961b1da213100d0c5113e83b6e2bfb /PKGBUILD
downloadaur-15db01c9c84b2b700f06b7a495cecd318ff0cbb5.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f53b95858ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Moritz Lipp <mlq@pwmt.org>
+pkgname=python2-printdesign
+_pkgname=python-printdesign
+pkgver=1.0
+pkgrev=rev497
+pkgrel=1
+pkgdesc="Open-source illustration program"
+arch=(any)
+url="http://sk1project.org"
+license=('GPL')
+depends=('python2' 'python2-uniconvertor')
+options=(!emptydirs)
+install=
+source=(http://sk1project.org/dc2.php?target=$_pkgname-$pkgver-${pkgrev}_all.deb)
+md5sums=('d4009fa0e71012cb6c6e46f00f111b3b')
+
+package() {
+ cd "$srcdir"
+ tar -xf data.tar.gz -C $pkgdir
+
+ # Fix python path
+ sed -i 's/python/python2/g' $pkgdir/usr/bin/printdesign
+
+ # Fix package path
+ mv $pkgdir/usr/lib/python2.7/dist-packages $pkgdir/usr/lib/python2.7/site-packages
+}
+
+# vim:set ts=2 sw=2 et: