summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2016-12-20 14:34:29 -0200
committerDanilo J. S. Bellini2016-12-20 14:34:29 -0200
commitf4548414507a0e168c1d7be1a44981f9eeca055c (patch)
tree9628ffc394104b3d6bbb6a5355087323326debdd /PKGBUILD
downloadaur-f4548414507a0e168c1d7be1a44981f9eeca055c.tar.gz
v1.6.2-1
v$md5sums")-1 find "$srcdir/$_name-$pkgver" \ cd "$srcdir/$_name-$pkgver"
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f53613ef834
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
+_name=Py6S
+pkgname=('python2-py6s')
+pkgver=1.6.2
+pkgrel=1
+pkgdesc="Python 2.7 interface to the 6S Radiative Transfer Model"
+arch=('any')
+url='http://py6s.rtwilson.com'
+license=('LGPL')
+makedepends=('python2-setuptools')
+depends=('6sv11' 'python2-scipy' 'python2-matplotlib' 'python2-pysolar')
+optdepends=('python2-pandas: AERONET data file support')
+options=(!emptydirs)
+md5sums=('41361f2bac39a1e9fbb11eb2a669b996')
+_pypi='https://pypi.python.org/packages'
+_path='8b/94/3feb8dd90ddfa4eeb9c5f73c1301c9642926b3fbbe074bae52cd71ba9d90'
+source=("$_pypi/$_path/$_name-$pkgver.tar.gz#md5=$md5sums")
+
+prepare() {
+ # Updates the shebang in Python scripts for Python 2
+ find "$srcdir/$_name-$pkgver" \
+ -name "*.py" \
+ -exec sed -i '1s/python\s*$/python2/' '{}' \;
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}