summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLingMan2021-06-27 10:21:54 +0200
committerLingMan2021-06-27 10:25:51 +0200
commit87fe594c0e29b5adbb824d64e42160dcfb3019c7 (patch)
tree3d9f679dcb996b0d8d17a1e291079f702c7a4532 /PKGBUILD
downloadaur-87fe594c0e29b5adbb824d64e42160dcfb3019c7.tar.gz
AUR submission after python2 support was dropped from the main repos in
https://github.com/archlinux/svntogit-packages/commit/10bf288cb6c8bf79e689f483674e53d1d906caa9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dddd846d2e8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+
+pkgname=python2-pyasn1-modules
+pkgver=0.2.8
+pkgrel=4
+pkgdesc="A collection of ASN.1-based protocols modules"
+arch=('any')
+license=('BSD')
+url="https://pypi.python.org/pypi/pyasn1-modules"
+depends=('python2-pyasn1')
+makedepends=('python2-setuptools')
+source=("https://pypi.io/packages/source/p/pyasn1-modules/pyasn1-modules-$pkgver.tar.gz")
+sha512sums=('fdfcaa065deffdd732deaa1fa30dec2fc4a90ffe15bd12de40636ce0212f447611096d2f4e652ed786b5c47544439e6a93721fabe121f3320f13965692a1ca5b')
+
+build() {
+ cd pyasn1-modules-$pkgver
+ python2 setup.py build
+}
+
+check() {
+ cd pyasn1-modules-$pkgver
+ PYTHONPATH=. python2 tests/__main__.py
+}
+
+package() {
+ cd pyasn1-modules-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname/
+}