summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTruocolo2024-01-31 16:01:41 +0100
committerTruocolo2024-01-31 16:01:41 +0100
commiteadb99ffd5d2eb4b22e80f1bec451384475ce27c (patch)
tree680504c48925f3b783f90688d274e246629e1b5d /PKGBUILD
parent1d2fd17c4ae1720bb835fb52331b7ae7324df380 (diff)
downloadaur-eadb99ffd5d2eb4b22e80f1bec451384475ce27c.tar.gz
add license
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD103
1 files changed, 76 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0a0b8c9b4c9..d5adddd46870 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,8 @@
+# SPDX-License-Identifier: AGPL-3.0
+#
+# Maintainer: Truocolo <truocolo@aol.com>
# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
-# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: prg <prg-archlinux@xannode.com>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
@@ -15,10 +18,15 @@ arch=(
i686
pentium4
aarch64
- armv7h)
+ armv7h
+ arm
+)
url="https://pypi.org/project/${_name}/${pkgver}"
-_repourl="https://github.com/${_name}/${_name}"
-license=('LGPL2.1' 'MIT')
+_url="https://github.com/${_name}/${_name}"
+license=(
+ 'LGPL2.1'
+ 'MIT'
+)
depends=(
'curl'
'glibc'
@@ -29,38 +37,79 @@ makedepends=("${_py}-setuptools")
_tagname="REL_${pkgver//./_}"
_tarname="${_name}-${_tagname}"
source=(
- "${_tarname}.tar.gz::${_repourl}/archive/refs/tags/${_tagname}.tar.gz")
+ "${_tarname}.tar.gz::${_url}/archive/refs/tags/${_tagname}.tar.gz")
b2sums=(
'f0cb9cc7687f75d73a1ddab2345b1bbb9ab9b6672344211c510d3b6e1d8a0a34c85beb94850a6079d00dbd19fce6ea6ca3998a0ad329250445aa705007554163')
prepare() {
- cd "${_tarname}"
-
- printf "Changing hashbangs in *.py files to refer to '${_py}'... "
- sed -e "1s|#![ ]*[a-z0-9._/]*/bin/[a-z0-9._/ ]*python.*|#!/usr/bin/env ${_py}|" \
- -i $(find . -name '*.py')
- echo 'done'
-
- echo "Disabling documentation inclusion in setup.py"
- sed -e $'/setup_args\[\'data_files\'\]/d' \
- -i 'setup.py'
+ cd \
+ "${_tarname}"
+ printf \
+ "Changing hashbangs in *.py files to refer to '${_py}'... "
+ sed \
+ -e \
+ "1s|#![ ]*[a-z0-9._/]*/bin/[a-z0-9._/ ]*python.*|#!/usr/bin/env ${_py}|" \
+ -i \
+ $( \
+ find \
+ . \
+ -name \
+ '*.py')
+ echo \
+ 'done'
+ echo \
+ "Disabling documentation " \
+ "inclusion in setup.py"
+ sed \
+ -e \
+ $'/setup_args\[\'data_files\'\]/d' \
+ -i \
+ 'setup.py'
}
build() {
- cd "${_tarname}"
- "${_py}" setup.py build
+ cd \
+ "${_tarname}"
+ "${_py}" \
+ setup.py \
+ build
}
package() {
- local _py_opts=(
- --root="${pkgdir}"
- --prefix='/usr'
- --optimize=1
- --skip-build)
- cd "${_tarname}"
- "${_py}" setup.py install "${_py_opts[@]}"
+ local \
+ _py_opts=()
+ _py_opts=(
+ --root="${pkgdir}"
+ --prefix='/usr'
+ --optimize=1
+ --skip-build
+ )
+ cd \
+ "${_tarname}"
+ "${_py}" \
+ setup.py \
+ install \
+ "${_py_opts[@]}"
- grep -A 100000 -e "^License$" 'README.rst' > 'LICENSE.rst'
- install --verbose -Dm 644 'LICENSE.rst' 'COPYING-MIT' -t "${pkgdir}/usr/share/licenses/${pkgname}"
- ln --verbose --symbolic '/usr/share/licenses/common/LGPL2.1/license.txt' "${pkgdir}/usr/share/licenses/${pkgname}/COPYING-LGPL"
+ grep \
+ -A \
+ 100000 \
+ -e \
+ "^License$" \
+ 'README.rst' > \
+ 'LICENSE.rst'
+ install \
+ --verbose \
+ -Dm 644 \
+ 'LICENSE.rst' \
+ 'COPYING-MIT' \
+ -t \
+ "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln \
+ --verbose \
+ --symbolic \
+ '/usr/share/licenses/common/LGPL2.1/license.txt' \
+ "${pkgdir}/usr/share/licenses/${pkgname}/COPYING-LGPL"
}
+
+# vim:set sw=2 sts=-1 et: