summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormschubert2019-01-07 10:37:52 +0100
committermschubert2019-01-07 10:37:52 +0100
commit0caa70618b6d885c42639cce136436c647f84714 (patch)
tree81e53683de13d2d23516a4e2913067c03ba1aac5 /PKGBUILD
parent8113f1f15ce14cacf06840f4f0282d6c30a391c7 (diff)
downloadaur-python2-pydstool.tar.gz
upstream moved to github
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8d4ee32c402..e775cacd9d4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,29 @@ _pkgname=${pkgname#python2-}
pkgver=0.90.2
pkgrel=1
pkgdesc="Simulation and analysis environment for dynamical systems"
-url="http://www.ni.gsu.edu/~rclewley/PyDSTool/FrontPage.html"
+url="http://pydstool.sf.net/"
license=('BSD')
arch=('any')
depends=('python2-numpy' 'python2-scipy')
makedepends=('dos2unix')
optdepends=('python2-sloppycell')
-replaces=('pydstool')
-source=("https://github.com/robclewley/$_pkgname/archive/v$pkgver.tar.gz")
+checkdepends=('python2-pytest' 'python2-pytest-xdist' 'python2-mock')
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/robclewley/$_pkgname/archive/v$pkgver.tar.gz")
options=('!emptydirs')
-md5sums=('35d69eae98b1c191d4689334862620f6')
+sha256sums=('f8fd7aa0f5c48d18b93f76e0086c4faf204e9fee9f32851f52bb67fa1450c891')
build() {
cd "$_pkgname-$pkgver"
python2 setup.py build
}
+# ERROR: file not found: discover
+# check() {
+# cd "$_pkgname-$pkgver"
+# python2 setup.py test
+# }
+
package() {
cd "$_pkgname-$pkgver"
- python2 setup.py install --skip-build --prefix="/usr" --root="$pkgdir" --optimize=1
+ python2 setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
}