summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2022-06-14 19:51:24 -0400
committerTed Alff2022-06-14 19:51:24 -0400
commitb4d3bc6624705eb2d8b201c0bc2af2edfcaad8c4 (patch)
treec0c88661b82cf948bfdb8045b99c2d4b78fbc431 /PKGBUILD
parentde93d586bbba2646baeddcc981c099021bb6dd40 (diff)
downloadaur-b4d3bc6624705eb2d8b201c0bc2af2edfcaad8c4.tar.gz
Version bump 2.0.3 (last python2 version)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f185a090563f..4b50fbc6ff0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,22 @@
# Maintainer: twa022 <twa022 at gmail dot com>
pkgname=python2-pygame
-pkgver=1.9.6
-pkgrel=2
+pkgver=2.0.3
+pkgrel=1
pkgdesc="Python game library"
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="http://www.pygame.org/"
license=('LGPL')
depends=('sdl_mixer' 'sdl_ttf' 'sdl_image' 'python2' 'portmidi')
makedepends=('python2-setuptools')
-source=("https://pypi.io/packages/source/p/pygame/pygame-$pkgver.tar.gz"
- 'include_stddef_for_offsetof.patch')
-sha256sums=('301c6428c0880ecd4a9e3951b80e539c33863b6ff356a443db1758de4f297957'
- '73874fbf335183ed309242fa648a73fb8f64e78ed89d9becad24a4f1b5d330c8')
+source=("https://pypi.io/packages/source/p/pygame/pygame-$pkgver.tar.gz")
+sha256sums=('d097f2802a9d0d7fb40c49c789af2984b202baa8fd32701082598755f5973f51')
prepare() {
cd pygame-${pkgver}
# don't ship python2 *and* python3 compiled bytecode from upstream
find . -name "*.pyc" -delete
find . -type f -exec sed -i 's#/usr/bin/env python#/usr/bin/env python2#' {} +
-
- patch -uNp2 -r- -i ../include_stddef_for_offsetof.patch
}
build() {