summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2017-03-14 16:49:03 +0000
committerGrey Christoforo2017-03-14 16:49:03 +0000
commiteac99d1d46f9fce5aaaed410afcaec0e8bba83a8 (patch)
tree9cf3999853979bcfab7056bf5699c211d9885fc2 /PKGBUILD
downloadaur-python2-pyina-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa3f630a4c61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=('python2-pyina-git')
+pkgver=152.5d8ba73
+pkgrel=1
+pkgdesc="MPI parallel map and cluster scheduling from git master"
+url="http://www.cacr.caltech.edu/~mmckerns/pyina.htm"
+depends=('python2' 'python2-dill' 'python2-mpi4py' 'python2-pox' 'python2-pathos')
+#optdepends=('python2-pyre')
+makedepends=('python2-setuptools')
+provides=('python2-pyina')
+conflics=('python2-pyina')
+license=('BSD')
+arch=('any')
+
+source=("git+https://github.com/uqfoundation/pyina#branch=master")
+md5sums=('SKIP')
+
+pkgver() {
+ cd pyina
+ #echo $(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g')
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd pyina
+ python2 setup.py build
+}
+
+package() {
+ cd pyina
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}