summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorApplebloom2018-02-18 12:47:59 +0100
committerApplebloom2018-02-18 12:47:59 +0100
commit6364f5ab396ac2a23d7d82799fe0e3de448fe708 (patch)
tree88d6b442e05bc1a79dde92f93e64a42bde0ef512 /PKGBUILD
parent807fed28bb9f48ca68430e13aded6184601aa85f (diff)
downloadaur-6364f5ab396ac2a23d7d82799fe0e3de448fe708.tar.gz
Fixed and updated the package. The python package is a submodule in mavlink repo,
so now only the mavlink repo is cloned, and then git submodule command fetches the pymavlink repo within it (obtaining latest commit from default branch). Also, added python2-future as dependency.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a759512a2714..3f1a5d16875f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,22 @@
_pkgname="python2-pymavlink"
pkgname="$_pkgname-git"
-pkgver=r2072.984cbd2
+pkgver=r2277.5f31f68
pkgrel=1
pkgdesc="Python bindings for MAVLink micro air vehicle marshalling / communication library."
arch=('any')
license=('GPL3')
url='http://qgroundcontrol.org/mavlink/start'
-depends=('python2-pyserial')
+depends=('python2-pyserial' 'python2-future')
makedepends=('git' 'python2-setuptools')
provides=($_pkgname)
conflicts=($_pkgname)
-source=("git+https://github.com/mavlink/mavlink.git"
- "git+https://github.com/ArduPilot/pymavlink.git")
-sha256sums=('SKIP' 'SKIP')
+source=("git+https://github.com/mavlink/mavlink.git")
+sha256sums=('SKIP')
prepare() {
cd "mavlink"
git submodule init
- git config submodule.pymavlink.url "$srcdir/pymavlink"
git submodule update
}