summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorApplebloom2016-04-05 06:08:20 +0200
committerApplebloom2016-04-05 06:08:20 +0200
commit69539d880fe5e1d85786c1ed0ee3a6ad64e17d61 (patch)
tree119f029e986245d0f441bb175419312fdb4f3499 /PKGBUILD
downloadaur-69539d880fe5e1d85786c1ed0ee3a6ad64e17d61.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d3d6a6a6629
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: AppleBloom <rat.o.drat@gmail.com>
+
+_pkgname="python2-pymavlink"
+pkgname="$_pkgname-git"
+pkgver=r1866.4a85883
+pkgrel=1
+pkgdesc="Python bindings for MAVLink micro air vehicle marshalling / communication library."
+arch=('any')
+license=('GPL3')
+url='http://qgroundcontrol.org/mavlink/start'
+depends=('python2-pyserial')
+makedepends=('git')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("git+https://github.com/mavlink/mavlink.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "mavlink"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "mavlink/pymavlink"
+ python2 setup.py build
+}
+
+package() {
+ cd "mavlink/pymavlink"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}