summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorApplebloom2016-10-01 19:15:02 +0200
committerApplebloom2016-10-01 19:15:02 +0200
commit72dfd141bf78122210a25c252277ee3b8dad9e6c (patch)
tree23858b42aeae6b102fa1613d383211d76030debe /PKGBUILD
parent69539d880fe5e1d85786c1ed0ee3a6ad64e17d61 (diff)
downloadaur-72dfd141bf78122210a25c252277ee3b8dad9e6c.tar.gz
Updated so it works now that pymavlink is a sub-module of mavlink.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d3d6a6a6629..54836c142fd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname="python2-pymavlink"
pkgname="$_pkgname-git"
-pkgver=r1866.4a85883
+pkgver=r2072.984cbd2
pkgrel=1
pkgdesc="Python bindings for MAVLink micro air vehicle marshalling / communication library."
arch=('any')
@@ -12,11 +12,19 @@ depends=('python2-pyserial')
makedepends=('git')
provides=($_pkgname)
conflicts=($_pkgname)
-source=("git+https://github.com/mavlink/mavlink.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/mavlink/mavlink.git"
+ "git+https://github.com/ArduPilot/pymavlink.git")
+sha256sums=('SKIP' 'SKIP')
-pkgver() {
+prepare() {
cd "mavlink"
+ git submodule init
+ git config submodule.pymavlink.url "$srcdir/pymavlink"
+ git submodule update
+}
+
+pkgver() {
+ cd "mavlink/pymavlink"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}