summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-16 02:35:57 +0200
committerMarcell Meszaros2022-06-16 02:35:57 +0200
commit30791904c8581cbd55fcf6ba5ecca218dca62cb9 (patch)
tree44c9bdb26c0149be2ec0205ab1857d3b0a03e0b3 /PKGBUILD
parenta36c8e2ad86aa29f9c787ef74e9531f1bfd48c9a (diff)
downloadaur-30791904c8581cbd55fcf6ba5ecca218dca62cb9.tar.gz
updpkg 21.0.0-4: hopefully fix tests, using the universally available C.UTF-8 locale
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce96dff025e2..98b314c0afa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname='python2-pyopenssl'
_name="${pkgname#python2-}"
pkgver=21.0.0
-pkgrel=3
+pkgrel=4
pkgdesc='Wrapper module for OpenSSL, legacy Python 2 version'
arch=('any')
url="https://pypi.org/project/${_name}/${pkgver}/"
@@ -44,12 +44,10 @@ build() {
}
check() {
- (
- echo 'Temporarily force-enabling UTF-8 encoding (LC_ALL=en_US.UTF-8) even if disabled; needed for the tests.'
- export LC_ALL=en_US.UTF-8
cd "${_tarname}"
- python2 setup.py pytest
- )
+ echo 'Running tests...'
+ echo '-- Using LC_ALL=C.UTF-8 locale to ensure UTF-8 filesystem encoding is used in Python 2'
+ LC_ALL=C.UTF-8 python2 setup.py pytest
}
package() {