summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarti Raudsepp2014-01-17 13:32:23 +0200
committerMarti Raudsepp2014-01-17 14:02:52 +0200
commit7d433d27444427a802a6ded66cb523aa618eaed1 (patch)
tree8cadf65404b2834aed64889f225bd66e829f7ea6 /PKGBUILD
downloadaur-7d433d27444427a802a6ded66cb523aa618eaed1.tar.gz
Update python2-weasyprint, add depend builds python2-pyphen and python2-cairocffi
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9baf88d4f8d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Marti Raudsepp <marti@juffo.org>
+_pypi_name='Pyphen'
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="Library to hyphenate text using included or external Hunspell hyphenation dictionaries"
+license=('GPL2' 'LGPL2.1' 'MPL')
+arch=('any')
+url="http://pyphen.org/"
+makedepends=('python2')
+depends=()
+pkgname="python2-pyphen"
+_pypi_name_inital=$(echo ${_pypi_name}|cut -c1)
+source=("https://pypi.python.org/packages/source/${_pypi_name_inital}/${_pypi_name}/${_pypi_name}-${pkgver}.tar.gz")
+
+package() {
+ cd "$srcdir/$_pypi_name-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ #rm -rf "$pkgdir/usr/bin" # Avoid a conflict: only keep the Py3 executable.
+}
+md5sums=('024fe88b78e7b65f02cba1c3165223e6')