summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrainDamage2015-10-02 21:22:40 +0200
committerBrainDamage2015-10-02 21:22:40 +0200
commitfe2656af75fc1f42eadd489aefbed7f2d254c318 (patch)
treebd0a23a193d252dd17e4c929ced6df066d630f91 /PKGBUILD
downloadaur-fe2656af75fc1f42eadd489aefbed7f2d254c318.tar.gz
initial version, adapted from python3 version of the package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..054d317fdc08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: BrainDamage
+pkgname=python2-readability-lxml
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="This is a python port of a ruby port of arc90’s readability project"
+arch=(any)
+url="https://github.com/buriy/python-readability"
+license=("custom:Apache")
+depends=("python2" "python2-chardet" "python2-cssselect" "python2-lxml")
+optdepends=()
+md5sums=("ba7bd3b90f2689472df0b10cc87ad5f2" "180667c7abbe3fa664518bfc5da9a145")
+source=("https://pypi.python.org/packages/source/r/readability-lxml/readability-lxml-$pkgver.tar.gz" "LICENSE")
+
+build() {
+ cd "$srcdir/readability-lxml-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ install -m644 -D LICENSE "$pkgdir/usr/share/licenses/python2-readability-lxml/LICENSE"
+ cd "$srcdir/readability-lxml-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --prefix="/usr"
+ install -m644 -D README "$pkgdir/usr/share/doc/python2-readability-lxml/README"
+}