summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAniket Pradhan2019-08-08 19:15:30 +0530
committerAniket Pradhan2019-08-08 19:15:30 +0530
commit1cd24fe3c3a4b7813a7b2cf080a1af5525bc4ebd (patch)
treeb2f86a16606d44a83bda7eedfef0f02b0840f6d6 /PKGBUILD
downloadaur-1cd24fe3c3a4b7813a7b2cf080a1af5525bc4ebd.tar.gz
Upgrade to v0.5.0
Also split the packages for python and python2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2bde215af04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Aniket Pradhan <aniket17133[at]iiitd[dot]ac[dot]in>
+# Contributer: Roman Haritonov <reclosedev[at]gmail[dot]com>
+
+_pkgname="requests-cache"
+pkgname="python2-requests-cache"
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="Transparent persistent cache for http://python-requests.org/ library ⛺ https://pypi.org/project/requests-cache/"
+arch=("x86_64")
+url="https://github.com/reclosedev/requests-cache"
+license=("BSD")
+depends=("python2" "python2-requests")
+makedepends=("git" "python2-setuptools")
+provides=("python2-requests-cache")
+conflicts=("python-requests-cache")
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/reclosedev/requests-cache/archive/v${pkgver}.tar.gz")
+sha256sums=('7846f008cd09ee1d38b5285bf098f9f0246cd1019d8c519d23184c1616342217')
+
+build() {
+ cd "$srcdir/$_pkgname-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README"
+}