summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-07-31 20:48:30 +0900
committerBenjamin Chrétien2015-07-31 20:48:53 +0900
commit492dbf7e16749873cc31c09e75c7dd6b1557e3dd (patch)
tree10f462c6a3aa226022c44918b84a7fb4a403fe88 /PKGBUILD
downloadaur-492dbf7e16749873cc31c09e75c7dd6b1557e3dd.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edb6cdce11ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=python2-rtsprofile
+_name=rtsprofile
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Library to read, manipulate and write RT system profiles using the RTSProfile XML schema"
+url="https://github.com/gbiggs/rtsprofile"
+depends=('python2')
+makedepends=('python2' 'python2-setuptools')
+license=('EPLv1.0')
+arch=('any')
+source=("https://github.com/gbiggs/${_name}/archive/${pkgver}.tar.gz")
+md5sums=('fd82cc2a8ca986e375d4eff613d8e102')
+
+# FIXME: probably some dependencies missing
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+
+ # Fix for Python 2 scripts
+ sed -i "s,env python *$,env python2,g" $(find . -type f)
+ sed -i "s,/usr/bin/python *$,/usr/bin/env python2,g" $(find . -type f)
+
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}