summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZachary Jordan2022-07-11 18:18:43 -0500
committerZachary Jordan2022-07-11 18:18:43 -0500
commitab1839c62bf92f5efa67cfbb51f6202e426f3462 (patch)
treeeb8ac514eb0c7515c523dc6722596cbae6c656c7 /PKGBUILD
parent9d8b1b0cc2f4f1b486eadea1752c2cef80336342 (diff)
downloadaur-ab1839c62bf92f5efa67cfbb51f6202e426f3462.tar.gz
re-enabled check()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82a8dafb6046..2c158934e6ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,14 @@
_base=simplejson
pkgname=python2-${_base}
pkgver=3.17.6
-pkgrel=4
+pkgrel=5
pkgdesc="Simple, fast, extensible JSON encoder/decoder for python2"
license=('MIT')
arch=('any')
url="https://github.com/${_base}/${_base}"
-depends=(python2)
-makedepends=(python2-setuptools)
+depends=('python2')
+makedepends=('python2-setuptools')
+checkdepends=('python2-pytest-runner')
source=(${url}/archive/refs/tags/v${pkgver}.tar.gz)
sha256sums=('5522f3113924325499f15cd8a3fe47a42dfa127a6b76c1921b51cf3c3f2a6aa6')
@@ -22,6 +23,11 @@ build() {
python2 setup.py build
}
+check() {
+ cd "${_base}-${pkgver}"
+ python2 setup.py pytest
+}
+
package() {
cd "${_base}-${pkgver}"
python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build