summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEli Schwartz2021-02-28 14:32:27 -0500
committerEli Schwartz2021-02-28 14:32:27 -0500
commitebeb275fc19d85ff70c3c1e7c69b2d54309b5d8a (patch)
tree8d0891f96931c2296ac7f5a612b7d38009ba409a /PKGBUILD
downloadaur-ebeb275fc19d85ff70c3c1e7c69b2d54309b5d8a.tar.gz
import from community
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8131611ec030
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: David Moore <davidm@sjsoft.com>
+
+pkgname=python2-simplejson
+pkgver=3.17.2
+pkgrel=4
+pkgdesc='Simple, fast, extensible JSON encoder/decoder for python2'
+license=('MIT')
+arch=('x86_64')
+url='https://github.com/simplejson/simplejson'
+depends=('python2')
+makedepends=('python2-setuptools')
+checkdepends=('python2-pytest-runner')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha512sums=('59428640d43fdc6927db752a36196f48d00818a87d924358deab7e498709515423ecdd34dece31364c5e8d64b63d99112fd4a4b8a03b9f9c6533268afc38e314')
+
+build() {
+ cd "${srcdir}"/simplejson-${pkgver}
+
+ python2 setup.py build
+}
+
+check() {
+ cd "${srcdir}"/simplejson-${pkgver}
+
+ python2 setup.py pytest
+}
+
+package_python2-simplejson() {
+ cd simplejson-${pkgver}
+
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}