summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Phillips2015-06-08 21:32:54 +1200
committerDavid Phillips2015-06-08 21:32:54 +1200
commit9d9d6add6782c12bccd98c4cc13390b084211bd9 (patch)
tree45de1bc8c72ca8a656d91c8cfe9dba7b5e3693ef /PKGBUILD
downloadaur-9d9d6add6782c12bccd98c4cc13390b084211bd9.tar.gz
First
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96761fcb9198
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Roberto Alsina <ralsina@kde.org>
+# Contributor: Fabio Varesano <fvaresano@yahoo.it> (Updated to 2.1.1a2)
+# Contributor: Martti Kühne <mysatyre@gmail.com>
+# Maintainer : David Phillips <gmail, dbphillipsnz>
+
+pkgname=python2-simpleparse
+_pkgname=SimpleParse
+pkgver=2.1.1a2
+pkgrel=2
+pkgdesc="A simple and fast parser generator"
+arch=('i686' 'x86_64')
+url="http://simpleparse.sourceforge.net"
+license=('custom')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("http://downloads.sourceforge.net/simpleparse/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('9899df932c6805dbb6433c7395e696fd60723f463513933e925cc77314c6bbb8')
+
+build () {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py bdist_dumb
+}
+
+package () {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ install -D license.txt "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ tar -xzv \
+ -f "${srcdir}/${_pkgname}-${pkgver}/dist/${_pkgname}-${pkgver}.linux"*".tar.gz" \
+ -C "${pkgdir}"
+
+}