summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-07 13:51:38 +0100
committerBartłomiej Piotrowski2018-01-07 13:51:38 +0100
commitfe29dee4b3c9e81aace93724ba92dd58798ccce3 (patch)
tree0b6ae046238199ab54d1fc1f0f4c29a5cfad922a /PKGBUILD
downloadaur-fe29dee4b3c9e81aace93724ba92dd58798ccce3.tar.gz
Import from official repositories
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77202f531d77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 276332 2017-12-28 05:13:56Z eschwartz $
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: Samuel Tardieu <sam@rfc1149.net>
+
+pkgname=python2-slowaes
+pkgver=0.1a1
+pkgrel=3
+pkgdesc="Implementation of AES in Python"
+arch=('any')
+url="https://code.google.com/archive/p/slowaes/"
+license=('Apache')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("https://pypi.python.org/packages/source/s/slowaes/slowaes-$pkgver.tar.gz")
+md5sums=('eafee95a788a795403e972a35e80ce4f')
+
+package() {
+ cd "$srcdir/slowaes-$pkgver"
+ sed -i 's#/usr/bin/python#/usr/bin/python2#' aes.py
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: