summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErhan SAHIN2015-07-03 02:15:26 +0300
committerErhan SAHIN2015-07-03 02:15:26 +0300
commit6810cfdf501624b6652aee8793c9694cac8afbb3 (patch)
tree13ca41af9496b4dd83606ad2ba348a4d8a4f2f01 /PKGBUILD
downloadaur-python2-swiftclient-liberty.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c873e89bbcb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Erhan SAHIN <erhan@ssahin.net>
+
+pkgname=python2-swiftclient-liberty
+pkgver=2.4.0
+pkgrel=1
+pkgdesc="Client Library for OpenStack Object Storage API"
+arch=('any')
+url="https://github.com/openstack/python-swiftclient"
+license=('Apache 2.0')
+depends=('python2' 'python2-requests' 'python2-keystoneclient')
+makedepends=('python2-distribute')
+source=('https://github.com/openstack/python-swiftclient/archive/2.4.0.tar.gz')
+md5sums=('d4b22f61461faf730e32cccf290a281a')
+
+build() {
+ cd "python-swiftclient-$pkgver"
+ echo -e "Name: python-swiftclient\nVersion: $pkgver" > PKG-INFO
+ sed -e 's|bin/python|bin/python2|' -i bin/swift
+}
+
+package() {
+ cd "python-swiftclient-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}