summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBruno Galeotti2015-06-08 15:36:32 -0300
committerBruno Galeotti2015-06-08 15:36:32 -0300
commitd5ddd0830fdba6eaebabca24861cccd9f6681c27 (patch)
tree9345702d42aade0d1b17e0c925387f34cb17de5d /PKGBUILD
downloadaur-d5ddd0830fdba6eaebabca24861cccd9f6681c27.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5eea83e26d2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Bruno Galeotti <bgaleotti at gmail dot com>
+
+pkgname=python2-tabulate
+pkgver=0.7.5
+pkgrel=1
+pkgdesc="Pretty-print tabular data in Python."
+arch=(any)
+url="https://bitbucket.org/astanin/python-tabulate"
+depends=('python2' 'python2-psutil')
+source=("https://pypi.python.org/packages/source/t/tabulate/tabulate-$pkgver.tar.gz")
+sha256sums=('9071aacbd97a9a915096c1aaf0dc684ac2672904cd876db5904085d6dac9810e')
+
+build() {
+ cd "$srcdir/tabulate-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/tabulate-$pkgver"
+ python2 setup.py install --root=$pkgdir --optimize=1
+ find "$pkgdir" -name '*.py' -print0 |xargs -0 \
+ sed -i -e 's,^#!/usr/bin/env python$,#!/usr/bin/env python2,' \
+ -e 's,^#!/usr/bin/python$,#!/usr/bin/python2,'
+}
+
+# vim:set ts=2 sw=2 et: