summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2019-12-15 16:30:39 -0300
committerRafael Fontenelle2019-12-15 16:30:39 -0300
commit0e6f7dda9180ffe34676fcc31eefedfb2e68039f (patch)
tree4c89eab4f663bb1b01a44cccf70f98076ef75c53 /PKGBUILD
parentd9c8ebcf7c4a2846472bedb3847bdf655f919b2d (diff)
downloadaur-0e6f7dda9180ffe34676fcc31eefedfb2e68039f.tar.gz
Update to 2.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 434566a2f078..2483b5ff6728 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,16 @@
pkgname=python2-translate-toolkit-lib
_name=translate-toolkit
-pkgver=2.3.1
+pkgver=2.4.0
pkgrel=1
pkgdesc="A toolkit to convert between various different translation formats, help process and validate localisations"
arch=('any')
url="http://toolkit.translatehouse.org/"
license=('GPL')
-depends=('bash' 'python2-lxml' 'python2-six' 'python2-diff-match-patch')
+depends=('bash' 'python2-lxml' 'python2-six' 'python2-diff-match-patch' 'python2-cheroot')
makedepends=('python2-setuptools')
-optdepends=('gaupol: for po2sub')
source=($_name-$pkgver.tar.gz::https://github.com/translate/translate/archive/$pkgver.tar.gz)
-sha256sums=('0b2d79f0023ce545c6240829624ce1e1ce54ea7bc7913428880345ff423fd999')
+sha256sums=('7f1d6a9566bb512fd88d51bd8bc920f42e379c91a4686761dbe89762f8a3a51d')
prepare() {
cd translate-$pkgver
@@ -21,14 +20,9 @@ prepare() {
$(find . -name '*.py')
}
-build() {
- cd translate-$pkgver
- python2 -s setup.py build
-}
-
package() {
cd translate-$pkgver
- python2 -s setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+ python2 -s setup.py install --root="${pkgdir}" --optimize=1
python2 -m compileall "$pkgdir/usr/lib/python2.7/site-packages/translate"
# keep tmserver and podebug for virtaal, and