summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorandalenavals2017-11-01 00:18:40 -0200
committerandalenavals2017-11-01 00:18:40 -0200
commit03872ce829a209b9c358e153f2a6413f0d796f37 (patch)
tree3e214bd1972001609193c809d46e849a5aa44f4a /PKGBUILD
downloadaur-python2-treecorr.tar.gz
Test must be defined in the close future
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a0cc31a06e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: M. Jarvis
+pkgname=python2-treecorr
+pkgver=3.3.7
+pkgrel=1
+#epoch=
+
+pkgdesc="A package for efficiently computing 2-point and 3-point correlation functions "
+
+
+arch=('x86_64')
+url="https://pypi.python.org/packages/5a/59/466fca95804e60a4ad0cf34de70e92fd57e6a711d09fbf1f0f8d00f833de/TreeCorr-3.3.7.tar.gz#md5=54bdf201d7e8a52b5fa9ea5e1ff1d101"
+license=('')
+groups=()
+depends=('python2' )
+makedepends=('git')
+checkdepends=()
+optdepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+options=()
+install=
+changelog=
+source=("${url}")
+#noextract=()
+md5sums=('54bdf201d7e8a52b5fa9ea5e1ff1d101')
+#validpgpkeys=()
+
+
+build() {
+ cd "$src"
+ cd "TreeCorr-$pkgver"
+ python2 setup.py build
+}
+
+
+package() {
+ cd "$src"
+ cd "TreeCorr-$pkgver"
+ python2 setup.py install --root=${pkgdir} --prefix=/usr
+
+}