summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSébastien Leduc2015-06-13 10:51:50 +0200
committerSébastien Leduc2015-06-13 10:51:50 +0200
commit48177bef3931b63967496cb1291553ad65c4776f (patch)
treeb547db48f2abb67782a79748726d41ed41d8992d /PKGBUILD
downloadaur-48177bef3931b63967496cb1291553ad65c4776f.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7997c51a7130
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Sebastien Leduc <sebastien@sleduc.fr>
+pkgname=python2-trollius
+_realname=trollius
+pkgver=1.0.4
+pkgrel=2
+pkgdesc="Port of the Tulip project (asyncio module, PEP 3156) on Python 2.7"
+arch=("any")
+url="https://bitbucket.org/enovance/trollius"
+license=('APACHE')
+depends=('python2' 'python2-futures')
+source=("http://pypi.python.org/packages/source/t/$_realname/$_realname-$pkgver.tar.gz")
+md5sums=('3631a464d49d0cbfd30ab2918ef2b783')
+
+package() {
+ cd "$srcdir/$_realname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: