summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormschubert2016-12-20 16:45:45 +0100
committermschubert2016-12-20 16:45:45 +0100
commitf99af46399c78e98a9c48cece89ad7fe6deeb18d (patch)
treeea314bcec8edc09bef156d389e9c81abe9b19a61 /PKGBUILD
parenta526a9f36d170bb4720085c3b00fd64e95614264 (diff)
downloadaur-f99af46399c78e98a9c48cece89ad7fe6deeb18d.tar.gz
version bump 0.1.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93416a702c65..c664a838ca09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,20 @@
# Maintainer: Michael Schubert <mschu.dev at gmail>
-
pkgname=python2-tsne
-pkgver=0.1
+pkgver=0.1.5
pkgrel=1
pkgdesc="Python library containing T-SNE algorithms"
arch=('any')
license=('BSD')
url="https://github.com/danielfrg/tsne"
-depends=('python2-numpy-openblas')
-source=("https://pypi.python.org/packages/source/t/tsne/tsne-$pkgver.tar.gz")
-md5sums=('b534c85f7f4dda6b42a02978d8722e6e')
+depends=('python2-numpy' 'python2-scipy' 'cblas')
+makedepends=('cython2')
+source=("https://github.com/danielfrg/tsne/archive/v$pkgver.tar.gz")
+md5sums=('8fe861e9cfe4021d9fd4383a46de11f8')
+
+prepare() {
+ # otherwise compile error due to duplicate definition
+ sed -i "/static inline double abs/d" "$srcdir"/tsne-$pkgver/tsne/bh_sne_src/quadtree.h
+}
build() {
cd "$srcdir/tsne-$pkgver"