summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTrygve Aaberge2016-02-07 14:41:43 +0100
committerTrygve Aaberge2016-02-13 23:56:18 +0100
commit89a0f594ec32ed9713bd0b42701aaa8ea6774bb0 (patch)
treebfb06f488e4cc20a002b25120f43bf05947460a2 /PKGBUILD
parentb5e492ec1f37e5b1d9ab1e3d313309cafae2c968 (diff)
downloadaur-89a0f594ec32ed9713bd0b42701aaa8ea6774bb0.tar.gz
Use GitHub as source instead of PyPI
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b16d6f5ee480..cdf777a17c86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,6 @@
pkgbase=python2-tunigo
pkgname=('python-tunigo' 'python2-tunigo')
-_pypiname=tunigo
pkgver=0.1.3
pkgrel=1
pkgdesc="Python API for the browse feature of Spotify"
@@ -10,13 +9,13 @@ arch=('any')
url="https://github.com/trygveaa/python-tunigo"
license=('APACHE')
makedepends=('python' 'python-setuptools' 'python2' 'python2-setuptools')
-source=("https://pypi.python.org/packages/source/t/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
-md5sums=('a8724b6964d76782cb7156a8b713fdce')
+source=("https://github.com/trygveaa/python-tunigo/archive/v${pkgver}.tar.gz")
+md5sums=('4d714cf59dd740179ab67fee54638ece')
package_python-tunigo() {
depends=('python' 'python-requests')
- cd "${srcdir}/${_pypiname}-${pkgver}"
+ cd "${srcdir}/python-tunigo-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
@@ -25,7 +24,7 @@ package_python-tunigo() {
package_python2-tunigo() {
depends=('python2' 'python2-requests')
- cd "${srcdir}/${_pypiname}-${pkgver}"
+ cd "${srcdir}/python-tunigo-${pkgver}"
python2 setup.py install --root="${pkgdir}/" --optimize=1
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"