summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSébastien Leduc2015-06-13 10:51:41 +0200
committerSébastien Leduc2015-06-13 10:51:41 +0200
commit58012efcf5441dcf43a7f5e937676ce08faeb8b7 (patch)
tree8a10ee98ed52d92bebb0ceffb4834dfc7f1e0e39 /PKGBUILD
downloadaur-58012efcf5441dcf43a7f5e937676ce08faeb8b7.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..712b5b77db75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Sébastien Leduc <seblu@aur.archlinux.org>
+# Contributor: Sébastien Luttringer <seblu@aur.archlinux.org>
+
+pkgname=python2-twitter
+_srcname=python-twitter
+pkgver=2.2
+pkgrel=1
+pkgdesc='Python 2 wrapper around the Twitter API'
+arch=('any')
+url='https://pypi.python.org/pypi/python-twitter'
+license=('APACHE')
+depends=('python2' 'python2-httplib2' 'python2-simplejson' 'python2-oauth2' 'python2-requests-oauthlib')
+makedepends=('python2-distribute')
+source=("https://pypi.python.org/packages/source/p/${_srcname}/${_srcname}-${pkgver}.tar.gz")
+md5sums=('eab697b3a9bc6bf3432d09a489f4ed8b')
+
+package() {
+ cd $_srcname-$pkgver
+ python2 setup.py install --root="$pkgdir"
+}
+
+# vim:set ts=2 sw=2 ft=sh et: