summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUko Koknevics2018-09-30 20:27:45 +0300
committerUko Koknevics2018-09-30 20:27:45 +0300
commit80c07bcfafb91385289b476baed22d948bb6bf53 (patch)
treec5c88590c8cb558597b6ad899e111cabe454f7f3 /PKGBUILD
downloadaur-python2-unqlite.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e6a33016666
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Uko Koknevics <perkontevs@gmail.com>
+# Python package author: Charles Leifer <UNKNOWN>
+pkgname=python2-unqlite
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="Fast Python bindings for the UnQLite embedded NoSQL database."
+arch=(any)
+url="https://github.com/coleifer/unqlite-python"
+license=(MIT)
+makedepends=("python2" "python2-pip")
+build() {
+ pip2 install --no-deps --target="unqlite" unqlite
+}
+package() {
+ mkdir -p $pkgdir/usr/lib/python2.7/site-packages/
+ cp -r $srcdir/unqlite/* $pkgdir/usr/lib/python2.7/site-packages/
+}